I just today tried upgrading my test installation today from 5.5.5 to 5.5.6. Both my test installation and live installation have been running 5.5.5 with no problems.

Initially I missed the fact that I was supposed to install the new .htaccess file.

I tried running the upgrade script and got a message telling me that there was a version conflict, I was running 5.5.5 but my log was telling me that I was on an earlier version. It gave me two options to upgrade from (5.5.5 and the previous version). Neither would work and I tried re-uploading the upgrade/install package several times and got the same error message each time.

So I posted on the 5.5.6 release thread and somebody pointed out that I needed to upgrade the .htaccess file. So I did that, re-installed the upgrade package and tried running the upgrade script again.

The error message then changed and told me that the language was not recognised. It told me to change it with tools.php.

So I uploaded tools.php to the /install directory and logged into it. I hit the phrase saying language and let the script run. I then went back to the upgrade process and that still did not work.

So what do I try next? To be clear, it doesn't matter how many times I try uploading the upgrade script and running it again, I always get the same error message about the language not being recognised and the instruction to change it in tools.php and whenever I hit the [language] script in tools.php this never makes any difference. I always get the same error message in the upgrade script.